BlockUI Requires jQuery v1.3 Or Later! Quick Fix

Many developers are reporting the following alert box message on their websites that use blockUI and jQuery:

blockUI requires jQuery v1.3 or later! You are using v1.10.0.

Fortunately, the solution is very simple, but it requires some out of the box thinking. What confused us was that we didn’t actually call the blockUI script at all on any of our websites, but we were still getting the message. It instantly clicked that this was some sort of dependency issue.

How To Fix BlockUI Requires jQuery v1.3 Or Later Message

Last night jQuery rolled out an update to its jQuery “latest” link, updating it to push out jQuery version 1.10.0. The problem is that the blockUI script cannot read the trailing zeros on this version, so it reads it as 1.1, which of course is a very dated version of jQuery. To fix this, we must remove our jQuery latest script and instead replace it with either a local copy of jQuery or the following Google Library version (we’re using 1.9.1 in this instance):

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js">
</script>

That should correct the problem! Let us know in the comments section if you have any additional solutions.

Allen Gingrich

Author Allen Gingrich

Allen has worked on the web for over a dozen years. Like many young entrepreneurs, he began with a small workspace in his basement, where he eventually formed Ideas and Pixels. The rest, well, is history. Allen enjoys fine wines, weight training, and beautiful, semantic code.

More posts by Allen Gingrich