BlockUI Requires jQuery v1.3 Or Later! Quick Fix

Many developers are reporting the following alert box message on their websites that use blockUI and jQuery:

blockUI requires jQuery v1.3 or later! You are using v1.10.0.

Fortunately, the solution is very simple, but it requires some out of the box thinking. What confused us was that we didn’t actually call the blockUI script at all on any of our websites, but we were still getting the message. It instantly clicked that this was some sort of dependency issue.

How To Fix BlockUI Requires jQuery v1.3 Or Later Message

Last night jQuery rolled out an update to its jQuery “latest” link, updating it to push out jQuery version 1.10.0. The problem is that the blockUI script cannot read the trailing zeros on this version, so it reads it as 1.1, which of course is a very dated version of jQuery. To fix this, we must remove our jQuery latest script and instead replace it with either a local copy of jQuery or the following Google Library version (we’re using 1.9.1 in this instance):

<script src="//">

That should correct the problem! Let us know in the comments section if you have any additional solutions.

Allen Gingrich

Author Allen Gingrich

Allen has worked on the web for over a dozen years. Like many young entrepreneurs, he began with a small workspace in his basement, where he eventually formed Ideas and Pixels. The rest, well, is history. Allen enjoys fine wines, weight training, and beautiful, semantic code.

More posts by Allen Gingrich
  • nonick

    Hi, where do we change this piece of code? Location? Thanks!

    • Just replace your jQuery call in the header with the code above. Voila!

      • That’s a hack how do we get rid of it the legit way.

        • I would imagine you could modify the blockUI script itself, doing a find search (CTRL+F) on “1.1”, then change that to read “1.10”.

          • Found a fix on the WordPress forum:

            “I was also getting the BlockUI error after updating to WordPress 3.6, it looks like WooCommerce was the culprit.

            Removing “alert(‘blockUI requires jQuery v1.3 or later! You are using v’ + $.fn.jquery);return;” (but not the “{” or “}” as nonick80 mentioned) fixed it for me.

            The files I needed to remove the line of code from were:




            Thanks for the tips and I hope my post and the rest here have helped people.”


          • John Ayling

            The fix is going to differ depending on what plugin or theme is using blockUI.

            Easiest way to track down is to view-source and see what folder jquery.blockUI.js is in.
            Then update the file by commenting out the check in function setup($).

            ie. do this:

            //if (/^1.(0|1|2)/.test($.fn.jquery)) {
            /*global alert:true */
            // alert(‘blockUI requires jQuery v1.3 or later! You are using v’ + $.fn.jquery);
            // return;

            Update the js file on your site and you should be good to go.

          • I so wanted this to work but it didn’t 🙁

          • Nirav

            Nice done. . .realy relexed now.

          • Julianne Rhodes

            where do I find this code?

      • Todd Benton

        Any idea how to do this in WordPress?

  • Newbee

    I think this sucks and that there should be an proper solution and description on how to change this. Their are a lot of newbee webmasters who don’t have all the knowledge and don’t know how and where to change the code. @mrgingrich: your answer is vague. Could you be more specific, thanks.

    • mrgingrich

      You think this sucks? That’s unfortunate — wish it could of been more helpful.

      • rtex

        Could have*

        • mrgingrich

          You’re the man.

  • Worked like a charm. Thanks dude!

    • mrgingrich

      Anytime! Glad to help.

      • Worked only for Chrome, in Safari the error persist. Solver with jQuery updater plugin in wordpress site

        • Julianne Rhodes

          Did you find a solution for other browsers?

    • Linda

      Not working for me. :o(

  • Eric

    Simple fix for frontend of wordpress sites, backend wp-admin will still display error if its needed but not such a bother to be on backend. kudos for quick simple fix

  • David

    Wp-includes > js > jquery > jquery.js there is a commented out title that has the 1.10 just change it to 1.9 yes this is hacking the core of wordpress but its a super easy fix, when 1.11 comes out in an update you wont have issues again.

    • Anahit Aida Ghazaryan

      Thx very much.This is really solved my problem!!

  • Terri Pie

    cool … thanks! it works

  • Thank you so much for this post! I had to get a little more involved and actually edit the included WordPress jquery.js file in wp-includes, as well as the script-loader.php script in wp-include. I know the next update will erase these changes, but hopefully by then it will be fixed. 🙂

  • InvolveLondon

    WP Plugin Sidebar Login also using BlockUI.js -was causing conflict with Latest WP Update 3.6
    Dev seems to have noticed and has provided an update 🙂

  • HverdagogFamilie Dk

    HI CAN’T any make a greath Plugin that deal with this problem
    PZ 😉

  • Linda

    I like your solution, but I’m not a developer and don’t know where to find the code to replace it.